Email delivery problems
Incident Report for GateHub
Resolved
This incident has been resolved.
Posted Jun 10, 2020 - 14:39 CEST
Investigating
Some emails are not being delivered. We are currently investigating the issue.
Posted Jun 10, 2020 - 13:58 CEST